Do you have questions ? We got the answers!

3
How to solve "Phone not registered on network" in Samsung Galaxy S3?

Open 2 Answers 7693 Views Gadgets

2 Answers

0

This is the common problem in some Galaxy S3, and there are 2 options to solve this:

  1. Turn off your phone, Remove SIM card, turn on your phone and again turn off, insert SIM card and now turn on your handset.
  2. Change the Mobile network mode to GSM/WCDMA (Auto) - Go to settings > more settings > mobile networks > network mode and make changes. I mean make it to automatic. (You may also try changing to other option and after few seconds change back to automatic mode.
answered Feb 25, 2013 by Ramz Guru (25,950 points)
1Comments
commented Mar 14, 2013 by anonymous
I have the same issue. But I've done that countless times, also flashed new roms clean install and all. Still don't have network. Only WiFi works. Any help please?
0
In your Phone: Go to settings<more settings<mobile networks- then touch the option network operators to scan the available networks in your area, wait for some moment, let your phone scan, a list of available networks in your area will appear then, select the network name of your service provider to register it and you are done. You can restart fore more efficient use then.
answered Apr 3, 2013 by imranraja Expert (560 points)
4Comments
commented May 8, 2013 by anonymous
i was also having the same problem and followed the method suggested by imranraja. Now its working fine.
commented May 12, 2013 by anonymous
i have done this and it says unable to connect try again later ?
commented May 16, 2013 by anonymous
i got the same msg & I did all suggested methods but didn't works .. still I have the same issue ..
commented Jun 15, 2013 by anonymous
i did what imranraja said but it not works... "unavailable to connect; try gain later" thats appear always everytime i registered on my service provider...
\
Copyright © 2013 - ask.drprem.com; user contributions licensed under Creative Commons License with attribution required.
...